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Introduction
About this document

1 Introduction

1.1 About this document

This document is intended as a guide for installation, maintenance and trou-
bleshooting of Portable Device Manager (WinPDM) and is relevant for:

• Installation and parameter setup
• Device administration and WinPDM daily use

The WinPDM provides a generic application for managing all devices (e.g.
handsets and chargers) on one or more sites. The WinPDM makes it possible
to edit parameters, update software in the devices and upload files. It can save
parameters and software for individual sites in a database.

NOTICE:  Features described in this document might be un-
available because they are not supported by your devices. A
feature can also be unavailable if a device is not selected (fea-
tures appear dimmed on the menu until having a device select-
ed).

1.2 Abbreviations and Glossary

Contacts The name of the phonebook in a handset.

CSV file Comma Separated Value: A file with data, where
values in each row are separated by a delimiter,
which can be a comma, a semicolon or a tab.

Device Can for example be a charger, desktop program-
mer, or a handset that is connected to WinPDM.

EAP Extensible Authentication Protocol

GUI Graphical User Interface.

JRE Sun Java Runtime Environment.

Language file Language file for handset or WinPDM.

License information file A file containing license keys for devices. The
file can be exported from the License Web and
imported to WinPDM.

License key The unique license key for a specific device with
a specific functionality.

Number Settings for the complete set of parameters of a
single device, tied to a specific identity.

Parameter definition file Defines the parameters for a device; for example
a handset.
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Requirements

WinPDM Portable Device Manager.

An application, running on a computer, for man-
agement of devices.

Package file A file including different types of files, such as
software files, parameter definition files or tem-
plate files.

Prefix First set of digits/characters of a telephone num-
ber. For example country code, PBX specific
codes etc.

Site Contains information of devices and Numbers.

Software file A file including software for a device.

Template General settings for a specific device. A template
can be applied to several Numbers of the same
device type.

USB Universal Serial Bus:

A serial bus standard to interface devices, for
example connect computer peripherals such as
mice, keyboards, scanners etc.

WiFi WiFi stands for Wireless Fidelity and is a term
developed by the Wi-Fi AllianceÂ® to describe
wireless local area network (WLAN) products
that are based on the Institute of Electrical and
Electronics Engineers' (IEEE) 802.11 standards.
Today, most people use WiFi as a reference to
wireless connectivity.

VoIP Voice over Internet Protocol

VoWiFi Voice over Wireless Fidelity: a wireless version
of VoIP and refers to IEEE 802.11a, 802.11b,
802.11g, and 802.11n network.

1.3 Requirements

See the Data Sheet for WinPDM.

1.4 WinPDM Description

1.4.1 WinPDM Terminology

This section gives a brief description of the basic terminology in WinPDM

A31003-M2000-J108-01-7631, 26/06/2020
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Device can be a charger, a desktop programmer or a
handset that can be connected to WinPDM.

Number the complete settings for a single device

Template general settings for a specific device type. A
template can be applied to several Numbers
of the same device type

License licensed functionality for a device.

Parameter definition file a file including all possible settings for a cer-
tain device type. Templates are created from
parameter definition files.

Package file a file that can contain other files, such as pa-
rameter definition files, software files and tem-
plate files.

A31003-M2000-J108-01-7631, 26/06/2020
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Installation and Configuration of WinPDM
Software Installation

2 Installation and Configuration of WinPDM
This section describes the basic settings required to getting started with the
WinPDM. The basic settings and the sequence in which they should be com-
pleted are illustrated in figure 1.

Basic settings

Install WinPDM
software

Create site
(initial startup)

2.1 Software Installation

NOTICE: Do not connect any devices to the computer before in-
stallation.

1) Locate the software provided by your supplier.
2) Double-click on the Setup.exe file located in the WinPDM x.x.x folder, where

x.x.x represents the software version of WinPDM.
3) Follow the instructions given by the Setup Wizard.

If an older version of WinPDM is installed, the setup wizard will uninstall the old-
er version before installing the newer WinPDM version.

2.2 Software Configuration

2.2.1 Initial Startup

1) In Windows, search for WinPDM. Refer to the vendor documentation for in-
formation about how to search for programs and files.

NOTICE:  Windows Firewall may alert you of “PMServer” etc.
You can ignore these security alerts, it will not affect the Win-
PDM, but then the alerts will appear every time the WinPDM is
started. A better way is to select Continue blocking or Unblock.

The very first time the WinPDM is started, a Create site window appears.

A31003-M2000-J108-01-7631, 26/06/2020
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Installation and Configuration of WinPDM

Figure 1: The Create site window

1) In the Site name field, enter a site name.
2) In the Description field, enter a description of the site (optional).
3) Click the OK button.

NOTICE:  Additional sites can also be created. See Site Man-
agement on page 24.
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Initial Configuration of Devices
Import Package Files

3 Initial Configuration of Devices
This section applies to new devices that shall be configured the very first time.
The devices are delivered with factory settings from the manufacturer. The initial
settings and the sequence in which they should be completed are illustrated in
Figure 2: Initial configuration of devices on page 11.

Create template
with common

settings

Import package
file for each
device type

Add numbers
and apply
template

Connect
device to 
computer

Associate 
number with 

device

Figure 2: Initial configuration of devices

3.1 Import Package Files

The package files (.pkg) for your devices are distributed by your supplier. The
package file includes the following:

• A software file (.bin) used for upgrading the device
• A parameter definition file (.def) including the parameters that can be config-

ured in the device.
• Templates might also be included. The templates can for example include

parameter settings for different exchange system.

NOTICE:  It is recommended to import the latest released pack-
age files for your devices.

1) From the File menu, select File management.

2) Click the Parameter definition tab and then click the Add button.
3) Select the package file (.pkg) to be imported and click the Open button.

3.2 Create Template with Common Settings

This section describes how to create a template including common settings that
can be applied to the device’s numbers later on.

1) Click the Templates tab.

A31003-M2000-J108-01-7631, 26/06/2020
Portable Device Manager, Installation and Operation Manual 11



Initial Configuration of Devices

2) From the Template menu, select New.

• Select which device type the template should be applicable for
• Select which parameter version the template should be based on. The

parameter version determines which parameter settings that are avail-
able for your device type. It is recommended to select the latest parame-
ter version to obtain full compatibly with the device.

• Enter an appropriate name of the template.
3) Click the OK button.
4) The Edit template dialog window opens showing parameters organized in a

tree structure in the left pane, with the parameters in the current node in the

right pane. Clicking the  icon will give a short description of selected pa-
rameter. In addition, see also the manual for the device for more information
about the parameter. Select the parameters to be saved in the template by
selecting the check box to the left o each parameter. Change the parameters
to the desired values.

In the Edit template window, the following color coding is used:

Color Description

Black Normal

Dark blue Parameter has been edited during the current ses-
sion

Purple The parameter is included in the template (checked)

Red Value not valid

Turquoise The value differs from the default value

A31003-M2000-J108-01-7631, 26/06/2020
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Create Numbers and Apply Template

5) When all needed parameters have been configured, click the OK button to
save the settings.

3.3 Create Numbers and Apply Template

This section describes how to create numbers to be associated with the devices
later on. In addition, the common settings will also be applied to the numbers
through the template you created earlier.

1) Click the Numbers tab.
2) From the Number menu, select New.

3) In the Device type drop-down list, select which device type the number(s) is
created for.

4) In the Parameter version drop-down list, select the same parameter version
used when you created the template for your device type.

5) In the Template drop-down list, select which template to be applied to the
number(s).

6) In the Prefix field, enter the prefix (if needed) to be added to the number(s).
7) Select one of the following options:
8) • To create a single number, select the Single option and enter the number.

• To create a range of numbers, select the Range option. Enter the start
number and end number. NOTE: The maximum range that can be added
at a time is 100 numbers.

9) Click the OK button.

3.4 Connect Device to Computer

This section describes how to connect the devices to the computer running Win-
PDM.

The device is connected to the computer running the WinPDM via the USB port.
The device must be set up to handle this connection according to the instruc-
tions in the manual for the device.

Example of connected devices are shown in Figure 3: Connection to the com-
puter running WinPDM on page 14.

A31003-M2000-J108-01-7631, 26/06/2020
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USB portWinPDM

Figure 3: Connection to the computer running WinPDM

Depending on connected device, a Device Wizard window or a New Number
Wizard window might be shown. In this case, click the Do nothing option and
then click the OK button.

Figure 4: The Device wizard

A31003-M2000-J108-01-7631, 26/06/2020
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Associate Number with Device

Figure 5: The New Number wizard

The device should now appear as online in WinPDM indicated by  in the On-
line column.

3.5 Associate Number with Device

This section describes how to configure the connected device with the number
you created earlier and also to apply the common settings for the device.

1) Click the Numbers tab.
2) Select the device to be associated with a number.
3) From the Numbers menu, select Associate with device.

4) Select the device to be configured with the selected number.
5) Click the OK button.

NOTICE:  If you cannot find your device in the list, the device is
not compatible with the parameter version used when you creat-
ed the number. In this case, the device’s software must first be
updated and then you can associate the number with the device.

A31003-M2000-J108-01-7631, 26/06/2020
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Upgrade a Device with New Software

3.6 Upgrade a Device with New Software

This section describes how to upgrade the software in a device. To be able to
associate a number with a device later on, the device’s parameter version must
be compatible with the number’s parameter version. The compatible parameter
version is applied to the device when upgrading the device’s software.

Additionally, newer software versions might be available since the device was
delivered from the manufacturer, and it is therefore recommended to upgrade
the device with the latest released software version.

1) Click the Devices tab.
2) Select the device to be upgraded.
3) Form the Device menu, select Upgrade software.
4) In the Available files drop-down list, select the software to be uploaded.

5) Click the OK button.

The software will be downloaded to the device. A progress bar in the Status
column for the device shows the progress of the download.

NOTICE:  To cancel the upgrade, right-click the device in the
list and select Cancel current upload.

The device will restart automatically after a successful download.
6) When the device has been upgraded; the upgrade status shows Complete,

the new software version, and the new parameter version for the device are
also shown.

Figure 6: Example of completed software upgrade

A31003-M2000-J108-01-7631, 26/06/2020
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The WinPDM GUI

4 Operation

4.1 The WinPDM GUI

4.1.1 WinPDM Window

The WinPDM window has a menu bar (1), four tabs (2) and a work area (3).
When a tab is selected, the available device types will be shown in the left hand
pane of the work area. The right pane of the work area shows devices, num-
bers, templates, and licenses already configured.

Figure 7: WinPDM overview

4.1.1.1 Search Field

In the upper part of the Work area there are search fields where different search
criteria can be selected depending on which tab that is displayed. The search
field is color coded green or red depending on if there are possible matches to
the search criteria or not.

4.1.1.2 Sort the List

By default the lists are sorted by the first column. To sort the list by any other
column, click the column heading. To reverse the sort order, click the column
heading again. The sort order is indicated by an up or down arrow in the column
heading.

4.1.1.3 Filter the List

By default the list in each tab shows all available Devices, Numbers or Tem-
plates. It is possible to filter the list by selecting a device type in left pane.

A31003-M2000-J108-01-7631, 26/06/2020
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4.1.2 Color coding

4.1.2.1 General color coding

• If the version number is shown in red, WinPDM has found no parameter defi-
nition files supporting that device type.

• If the version number is shown in dark red, the parameter definition file is
compatible, but does not have exactly the same version as the device.

4.1.2.2 Color coding for parameter and template editing

In the parameter and template editing window, the following color coding is
used:

Color Context Description

Black General Normal

Dark blue For templates and parame-
ter editing

Parameter has been edited during
the current session

Purple For templates The parameter is included in the
template (checked)

Red For templates and parame-
ter editing

Value not valid

Turquoise For templates and parame-
ter editing

The value differs from the default
value

4.1.3 Tabs

4.1.3.1 Devices Tab

A31003-M2000-J108-01-7631, 26/06/2020
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The view shows all devices configured at the site in a detailed list. The following
information can be displayed:

• Description — optional information of a device that can be added by the Win-
PDM user. For example, the user of the device.

• Device ID — the unique identifier of the device.
• Device type — the device model.
• Software version — the version of the software in the device.
• Parameter version — the version of the parameters in the Number
• Status — might show one of the following symbols:

— new software upgrade is in progress (a green arrow).

It is also possible to see a progress bar when the device is being up-
graded.

 — software upgrade Pending, Request sent, or Accepted.

— Retrying

— the last upgrade Failed or Aborted (a red broken arrow).

• Online — shows if the device is connected to the computer running Win-
PDM. When connecting a device to the WinPDM, it might take a while before

the device goes online. The  symbol indicates a device that has become
connected/online.

• Latest number - shows the latest known Number for a device.

4.1.3.2 Numbers Tab

Figure 8: The Numbers tab

The view shows all Numbers configured at the site in a detailed list. The follow-
ing information can be displayed:

• Description — optional information of a device that can be added by the Win-
PDM user. For example, the user of the number.

• Number — the unique identifier of the Number. The identifier is unique for
that device type.

• Device type — the device model the Number is intended for.

A31003-M2000-J108-01-7631, 26/06/2020
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• Parameter version — shows the version of the parameters in the Number.
• Device ID — the unique identifier of the device that the Number is associat-

ed to.
• Online — shows if the device the Number is uploaded to is connected to the

computer running WinPDM. It might take a while before a connected device

goes online in the WinPDM. The  symbol indicates a device that is on-
line/connected.

• Status — shows the parameter synchronization status. A Number can also
be queued for synchronization. Several different indications are used, for ex-
ample Synchronizing, Synchronized, etc. When the Number is offline, the
status Synchronized or Not synched is shown.

• Saved — shows if the Number’s parameters have been stored in the data-

base. The  symbol indicates that the parameters have been stored.
• Last login — shows the latest date and time the device was online in Win-

PDM/logged in to WinPDM.
• Last run template - indicates which template that was last run for that Num-

ber.

4.1.3.3 Templates Tab

The view shows all templates configured at the site in a detailed list. The follow-
ing information can be displayed:

Figure 9: The Templates tab

• Name — the name of the template.
• Device type — the device model.
• Parameter version — shows the parameter version.

4.1.3.4 Licenses Tab

NOTICE: The License tab might not be applicable for all hand-
sets.
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Figure 10: The Licenses tab in WinPDM

The view shows all devices configured at the site in a detailed list. The following
columns are displayed:

• Device ID — the unique identifier of the device.
• Device type — the device model.
•

Online — shows if the device is connected to the WinPDM. The  symbol
indicates that the device is online.

• Serial number — the number identifying the device hardware.
• Number — the unique identifier of the Number. The identifier is unique for

that device type.
• Software version — shows the version of the software in the device
• Status — shows the license synchronization status.
• Examples of status that can be shown are.
• "Sending" means that WinPDM is sending license information to the device.
• "Server failure" means that there is some kind of error with the communica-

tion between WinPDM and the license server.
• "Needs update" - An attempt to move a license from one handset to another

has been made, but the latest license does not exist in the handset.

In the bottom of the work area, the license options of the device are listed and
whether the options are enabled or not.

4.1.4 Language Settings for WinPDM GUI

It is possible to select the language to be used in the menus in WinPDM by im-
porting a language file with the file extension *.xml.

The default language is english, and stored as a default translations file in your
installation directory at installation:

C:\Program Files\ASAB\WinPDM\Client\default-translation-
s.xml

This file can be copied and edited to create a new language and can then be
imported as described below.
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The Device Wizard

1) From the Options menu, select Select language.

2) Click the Import button.
3) Select the language file (.xml) to be imported and click the Open button.
4) In the Available languages drop-down list, select which language to use.
5) Click the OK button.

INFO:  For adding a new language to a device, see Import Lan-
guage Files for Devices on page 42 and Delete Imported
Files for Devices on page 43.

4.2 The Device Wizard

When a device without a number is connected to the WinPDM, the Device Wiz-
ard window appears.

Figure 11: The Found Device Wizard window.

There are four choices in the wizard:
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Open the WinPDM

• Associate with number, see Associate a Number with a Device on page
29.

• Edit parameters, see also Edit Parameters on page 28.
• Apply template, see also Apply Template to set Parameter Values on page

28.
• Do nothing.

4.2.1 The New Number Wizard

When a new device with an unsaved Number is connected, the New Number
Wizard window appears.

Figure 12: The New Number Wizard window

There are four choices in the wizard:

• Store in database
• Edit parameters, see also Edit Parameters on page 28.
• Apply template, see also Apply Template to set Parameter Values on page

28.
• Do nothing.

4.3 Open the WinPDM

In Windows, search for WinPDM. Refer to the vendor documentation for infor-
mation about how to search for applications.

The view of the last used Site opens. To open another site, see Open Site on
page 24.
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Site Management

4.4 Site Management

By creating a Site for each customer installation, devices, software and licenses
can be managed for that site. The settings are saved in a database.

NOTICE:  There is a subtle but important difference between
loading and opening a site. When a site is opened, the Site man-
agement dialog closes and it is possible to start working with the
devices in the site. When a site is loaded, the Site management
dialog stays open, making it possible to continue with site man-
agement tasks, such as creating and deleting sites.

Figure 13: The Site management window

4.4.1 Create New Site

1) From the File menu, select Site management.
2) Click the New button.
3) Enter a name for the site and a description (optional) and click the OK but-

ton.

4.4.2 Open Site

1) From the File menu, select Site management.
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2) Select the site to be opened and click Open.

4.4.3 Load Site

1) From the File menu, select Site management.
2) Select the site to be loaded.
3) Click the Load button. The view in the main window changes to the newly

opened site.

4.4.4 Delete Site

1) From the File menu, select Site management.
2) Make sure that the site to be deleted is not currently active. If it is active,

load another site (see Load Site on page 25).

NOTICE:  If there is only one site remaining, it cannot be
deleted.

3) Select the site to be deleted and click the Delete button.
4) Click the Yes button to confirm the deletion.

4.4.5 Import Site

When importing a site, numbers with parameters and devices are imported.
Templates, software and definition files are not imported.

1) From the File menu, select Site management.
2) Click the Import button.
3) Select the Site file (.ste) to be imported and then click the Open button.
4) In the Input dialog, enter a name for the site and click the OK button.

4.4.6 Export Site

From the File menu, select Site management.

Select the site to be exported and click the Export button.

Select the location where the exported file should be saved.

Enter a file name of the site (.ste) and then click the Save button.

4.5 Numbers

4.5.1 Create New Numbers

1) Click the Numbers tab.
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2) From the Number menu, select New.
3) In the Device type drop-down list, select device type.
4) In the Parameter version drop-down list, select the parameter version.
5) In the Template drop-down list, select which template to apply to the Num-

ber. This is optional and therefore “None” can be selected.
6) In the Prefix field, enter the Number’s prefix (if needed).
7) Select one of the following options:
8) • To create a single Number, select the Single option and enter the call

number.
• To create a range of Numbers, select the Range option. Enter the start

call number, end call number.

NOTICE:  The maximum range that can be added at a
time is 100 Numbers.

9) Click the OK button.

4.5.2 Save a Number to Database

The number of an online device can be saved to the database.

1) Click the Numbers tab.
2) Select the device which number to be saved.
3) From the Number menu, select Save.

4.5.3 Enter/Edit Description of a Number

It is possible to enter information of a Number using WinPDM. For example, the
description can be used to describe a user of a number.

1) Click the Numbers tab.
2) Select the number which description to be edited.
3) From the Number menu, select Enter description.
4) Enter an appropriate description and then click the OK button.

4.5.4 Manage Certificate for a VoWiFi Handset

Certificates are used for authentication between handsets and systems (e.g.
WLAN and IP-PBX). Authentication is the process of verifying the identity of
handsets and systems. This can be used to ensure that only communication be-
tween trusted handsets and a trusted system can be established.

There are two types of certificates than can be imported to the handsets:

• Trusted certificate: All certificates the handset should trust are imported to
the handset’s Trust list. When a system sends its certificate to authenticate
itself to the handset, the handset checks if the certificate is trusted. The sys-
tem’s certificate or Certificate Authority (CA) certificate that trusts the sys-
tem’s certificate can be imported.

• Application certificate: An application certificate is the one the handset uses
to authenticate itself by sending the certificate to the system. Depending on
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how the system is configured, it might check if the application certificate is
trusted.

4.5.4.1 Import Certificates

Import of nested certificates (i.e. certificate chains) in one common file is not
supported. Instead, import each certificate as a separate file.

1) Click the Numbers tab.
2) Select the number which certificates to be managed.
3) From the Number menu, select Manage certificates.
4) Click the Trusted list tab or the Application certificates tab depending on

which certificate to be imported.
5) Click the Browse button and locate the certificate file to be imported. The

following certificate formats are supported: .cer, .der, .crt, .pem, .p12, .pfx,
and .p7b.

6) If the certificate is passport protected, enter the password and then click the
OK button.

A Confirm Certificate window opens showing the details of the certificate.
7) Import the certificate to the device by clicking the Yes button.

If needed, repeat step 3 - 7 for importing additional certificates.

NOTICE:  Additional settings for certificates might be needed in
the handset, refer to the handset documentation.

4.5.4.2 View Certificate Details

1) Click the Numbers tab.
2) Select the device which certificates to be viewed.
3) From the Number menu, select Manage certificates.
4) Click the Trusted list tab or the Application certificates tab depending on

which certificate to be viewed.
5) Select the certificate to view by clicking the i icon next to the certificate.

A Certificate details window appears.

4.5.4.3 Remove Certificate

1) Click the Numbers tab.
2) Select the device which certificates to be removed.
3) From the Number menu, select Manage certificates.
4) Click the Trusted list tab or the Application certificates tab depending on

which certificate to be removed.
5) Select the certificate to remove by clicking the corresponding Remove but-

ton.
6) Confirm the deletion by clicking the Yes button.
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4.5.5 Edit Parameters

The Edit Parameters window shows the set of parameters for the Device/Num-
ber. The parameters are organized in a tree structure in the left pane, with the

parameters in the current node in the right pane. Clicking the  icon will give
a short description of selected parameter.

NOTICE:  If Edit parameters was selected in the Device Wizard
window, or in the New Number Wizard window, continue from
step 4.

1) Click the Numbers tab.
2) Select the device which parameters to be edited.
3) From the Number menu, select Edit.

4) In the left pane, select the parameters to be edited.
5) In the Value column, make your changes.

When a parameter has been edited, the node in the left pane changes to a
blue color.

6) Click the OK button to save the changes, or click the Cancel button to undo
all parameter changes. When saving the changes, the parameters are auto-
matically sent to the device when it is online in WinPDM.

4.5.6 Apply Template to set Parameter Values

If a template has been created for a device type, it can be used to set the para-
meter values for a range of devices, or a single device.

NOTICE:  If Apply template was selected in the Device Wiz-
ard dialog window, or in the New Number Wizard dialog window,
continue from step 4.

1) Click the Numbers tab.
2) Select the device(s) you want to apply the template on.
3) From the Number menu, select Apply template.
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4) Select the template to be used and click the OK button.

4.5.7 Associate a Number with a Device

Before being able to synchronize parameters between WinPDM and devices, it
is necessary to associate a Number with a device. It is possible to enter several
Device IDs in advance and to associate them with a Number at a later moment.

NOTICE:  If Associate with number was selected in the De-
vice Wizard window, continue from step 3.

1) Click the Numbers tab.
2) Select the number you want to associate with a device.
3) From the Number menu, select Associate with device.
4) Select the device you want to associate with in the list and click the OK but-

ton.

NOTICE:  If the selected device is online, it will immediately be
updated with the selected Number. If the selected device is not
online, it will be updated the next time it is online.

It is possible to associate several Numbers with several devices simultaneously.

4.5.8 Delete a Number in the Site Database

1) Click the Numbers tab.
2) Select the device which number you want to delete.
3) From the Number menu, select Delete.
4) In the Delete Numbers window, click the Yes button.

NOTICE:  If a device that is online is deleted, it will stay in the
list as online but not saved.

4.5.9 Rename a Number

1) Click the Numbers tab.
2) Select the device which Number you want to rename.
3) From the Number menu, select Rename.
4) In the Rename number window, enter a new prefix (optional) and a new

Number and click the OK button.

4.5.10 Copy a Number

Click the Numbers tab.

Select the device which Number you want to copy.
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From the Number menu, select Copy.

In the Copy number window, enter a new prefix (optional) and a new Number
and click the OK button.

4.5.11 Import Contacts

NOTICE:  The number for the device must be saved, see Save
a Number to Database on page 26.

4.5.11.1 Import Contacts From File

A file containing contacts can be imported to WinPDM and synchronized with a
device. This can for example be useful when you want to transfer contacts from
legacy devices to newer devices.

When importing the file, the device’s contacts (if any) are overwritten by the
contacts in the file. Additionally, the import works only if the device can store all
contacts included in the file. For example; if the file contains 100 contacts, the
device must have support for storing at least 100 contacts.

If needed, the number of contacts in the file can be changed by using Excel or
other compatible application.

1) Click the Numbers tab.
2) Select the number which the contacts should be imported to.
3) From the Number menu, select Import contacts > From file.
4) Select file containing contacts (.txt, .csv, or .skv). Click the Open button.

The contacts in the imported file are synchronized with the device.

4.5.11.2 Import Contacts From Number

You can make a copy of a device’s contact list and paste it to another device’s
contact list directly. This means that the contact list do not need to be saved on
for example your computer.

NOTICE:  The import works only if the receiving device can
store the entire contact list of the device you are importing from.
For example; if the contact list contains 100 contacts, the receiv-
ing device must have support for storing at least 100 contacts.
Additionally, the Company phonebook contacts included in the
contact list are not transferred to the other device using this fea-
ture.

1) Click the Numbers tab.
2) Select the number which the contacts should be imported to.
3) From the Number menu, select Import contacts > From number.
4) Select the number which contacts to be copied.
5) Click the OK button.

The contacts are now imported to the handset.
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4.5.12 Export Contacts

You can make a copy of a device’s contact list that can be used as backup
(.csv). The contact list can also be imported to another supporting device later
on (see Import Contacts From File on page 30).

1) Click the Numbers tab.
2) Select the device which contacts to be exported.
3) From the Number menu, select Export contacts.
4) Enter a descriptive file name and click the Save button.

4.6 Devices

NOTICE: This chapter is not applicable for the desktop program-
mer (DP1). Just connect the DP1 to the computer’s USB port
and then put the VoWiFi handset in the programmer to get start-
ed. The DP1 will not appear as a device in the WinPDM.

All work with devices is performed from the Devices tab.

• Devices can be added to a site by connecting the device to the computer.
• It is possible to transfer the information for a device to another device.
• Devices can be reset to factory settings.
• Devices can be updated with new software.

4.6.1 Add Devices to a Site

Before connecting a device to the WinPDM, make sure the connection is set up
according to the instructions in the device’s manual (for example, Installation
Guide or Configuration Manual).

If a range of new devices are to be added to a site, the easiest way is to:

1) Create a template with all common parameter settings for the site. See Cre-
ate a Parameter Template on page 34.

2) Add a range of Numbers and run the template. See Create New Numbers on
page 25 and Apply Template to set Parameter Values on page 28.

3) Edit the parameters and change individual settings. See Edit Parameters on
page 28.

4) Connect the physical devices, one after the other, and associate them with
the Numbers in the site database. See Associate a Number with a Device on
page 29.

A single device can be added in the same way.

4.6.2 Synchronize a Device

When a device is connected, it is synchronized with the associated Number in
the WinPDM.

When a device is being synchronized, parameters that have been changed
in the device are uploaded to the WinPDM, and parameters that have been
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changed in the WinPDM are sent to the device. If a parameter has been
changed in both the device and the WinPDM, the setting made in the WinPDM
will take precedence.

1) Click the Numbers tab.
2) Connect a device to the computer running the WinPDM. If the Number is

saved, and it has a parameter definition, the device is automatically synchro-
nized.

4.6.3 Delete a Device in the Site Database

1) Click the Devices tab.
2) Select the device to be deleted.
3) From the Device menu, select Delete.
4) In the Delete Device window, click the Yes button.

NOTICE:  It is not possible to delete a device that is online in
WinPDM.

4.6.4 Replace a Device

If a device should be replaced with a new one, it is possible to transfer its as-
sociated Number to a new device. The new device must be of the same device
type as the old one.

1) If the device to be replaced is still working, make sure that it is synchronized.
2) Connect the new device to the WinPDM.

Associate the new device to the Number associated to the old device as fol-
lows:

3) Click the Numbers tab.
4) From the Number menu, select Associate with device.
5) Select the device you want to associate with in the list and then click the OK

button. The Number is no longer associated to the old device.

4.6.5 Create New Device

It is possible to enter several new Device IDs in advance into WinPDM for later
association.

In order to simplify input when handling many devices, it is possible to use a bar
code reader. The bar code reader should send a carriage return after each item,
but it is not necessary. If carriage return is not sent, it is necessary to click Cre-
ate after each read item.

1) Click the Devices tab.
2) From the Device menu, select Add device.
3) Select device type and parameter version.
4) Enter a Device ID for the device, manually or by using a bar code reader.
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5) The Continuous registration check box can be used to select whether the
Create devices dialog shall close after clicking Create or if it shall still be
open.

6) Click the Create button.
7) Repeat 4 to 6 if more devices are to be created.

4.6.6 Assign a Number

It is possible to assign a Number to a device that has not yet been assigned a
Number in WinPDM.

NOTICE:  Assign should not be done on a device that already
has a Number.

1) Click the Devices tab.
2) Select the device that should be assigned a Number.
3) From the Devices menu, select Assign number.
4) In the Assign number to device window, enter a new prefix (optional) and a

new Number
5) Click the OK button.

4.6.7 Enter/Edit Description of a Device

It is possible to enter information of a device using WinPDM. For example, the
description can be used to describe a location of a device.

1) Click the Devices tab.
2) Select the device which to edit the description for.
3) From the Device menu, select Enter description.
4) Enter an appropriate description and click the OK button to save the setting.

4.6.8 Factory Reset

Factory reset means that the device parameters will be set to factory default
settings. The Number in the database that is associated with the device will not
be affected.

NOTICE:  The device must be online.

1) Click the Devices tab.
2) Select device(s) to be reset.
3) From the Device menu, select Factory reset.
4) Click the Yes button.

4.6.9 Device Properties

To get a summary of the properties of a device:
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1) Click the Devices tab.
2) Select the device which properties you want to show.
3) From the Device menu, select Properties.

The following information is displayed:

• Description of the device (if entered by the WinPDM user)
• Device ID
• Device type
• Parameter version
• Software version
• Last known number
• Online status
• File upload information

4.7 Templates

Templates are a collection of user defined parameter values. These templates
can be used to create common settings to be used on several devices of a cer-
tain device type.

NOTICE:  Templates created in one site are also selectable in
the other sites used in WinPDM.

4.7.1 Create a Parameter Template

1) Click the Templates tab.
2) From the Template menu, select New.
3) Select device type and parameter version, enter a name for the template,

and click the OK button.

NOTICE:  If the wanted device type and/or parameter version
is not found in the list, WinPDM needs to be updated with
new parameter definition files, see Import Parameter Defini-
tion Files on page 41.

4) In the Edit Template window, select the parameters to be saved in the tem-
plate by selecting the check box to the left of each parameter. Change the
parameters to the desired values.

5) Click the OK button.

4.7.2 Create a Parameter Template from a Number

It is also possible to create a template from a number in the WinPDM. This can
be used to save settings in the template that later on can be applied to other
numbers.

1) Click the Numbers tab.
2) Select the number which settings to be used as template.
3) From the Template menu, select Use as template.
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4) Enter a name for the template.
5) Click the OK button.

When creating a template based on a number, a Select drop-down list is
shown in the bottom left corner. This setting decides which parameters that
shall be copied from the device. If All parameters is selected, the synchro-
nization time will be longer.

6) Select the parameters to be saved in the template by selecting the check
box to the left of each parameter. Change the parameters to the desired val-
ues

It is also possible to create a template from a device that is online but not stored
in the database. The template will contain all parameters for the device except
for those that are Number specific.

4.7.3 Rename a Template

1) Click the Templates tab.
2) Select the template to be renamed.
3) From the Template menu, select Rename.
4) In the Rename template window, enter a new name and then click the OK

button.

4.7.4 Copy a Template

1) Click the Templates tab.
2) Select the template to be copied.
3) From the Template menu, select Copy.
4) In the Copy template window, enter a new name and then click the OK but-

ton.

4.7.5 Edit a Template

1) Click the Templates tab.
2) Select the template to be edited.
3) From the Template menu, select Edit.
4) In the Edit template window, edit the parameters and then click the OK but-

ton.
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4.7.6 Delete a template

1) Click the Templates tab.
2) Select the template to be deleted.
3) From the Template menu, select Delete.
4) In the Delete template window, click the Yes button.

4.7.7 Upgrade a Template

NOTICE: In order to upgrade a template, the new parameter
version must have the same major version as the old parame-
ter version. For example, upgrading from 25.8 to 25.9 works, but
upgrading from 25.8 to 26.x does not work.

1) Click the Templates tab.
2) Select the template to be upgraded.
3) From the Template menu, select Upgrade.
4) Select the parameter version to upgrade to and then click the OK button.

4.7.8 Apply a Template

1) Click the Templates tab.
2) Select the template to be used.
3) From the Template menu, select Apply to.

INFO:  It is possible to search for a device in the list using the
Search field.

4) Select device(s) to apply the template on and then click the OK button.

4.8 Licenses

This feature might not be applicable for all devices.

This section describes the device licensing features that can be done using the
WinPDM. An overview of the device licensing concept is described in the Func-
tion Description for Product Licensing Overview documentation. Device licens-
ing offers a possibility to view, manage and upgrade licenses of devices.
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4.8.1 License Upgrade Alternatives

License upgrade includes using the license web which is described in the Func-
tion Description, Product Licensing Overview documentation.

These are the alternatives for upgrading licenses on devices:

• Automatic license upgrade Used when the WinPDM has an Internet connec-
tion to the license server, see Automatic License Upgrade on page 37.

• License upgrade using export/import Used when the WinPDM does not have
an Internet connection, see Export and Import Licensing Information on page
37.

• Manual license upgrade Used to enter the license key manually in the de-
vice, see the manual for the corresponding device. In this case, the WinPDM
is not used.

4.8.2 Automatic License Upgrade

NOTICE:  This feature requires an Internet connection.

The first time a device logs in to the WinPDM, it asks the license server if any
licenses are available for the device. When the device logs in at a later time,
there is no automatic check for licenses. If changes have been made, a manual
upgrade must be done by selecting Refresh, see Refresh on page 39.

Automatic license upgrade is a way of upgrading automatically to the correct li-
cense for a device. In order to get a purchased license for a device, a connec-
tion with the license server is made. The WinPDM automatically gets device li-
censing information from the device, sends it to the license server which returns
a license key that the WinPDM sends to the device. The device upgrades and
the correct license information is shown in the WinPDM and the device.

4.8.3 Export and Import Licensing Information

In order to upgrade licenses on devices when the WinPDM does not have an in-
ternet connection to the license server, the following is done:

• The information needed for licensing of a device is exported from the Win-
PDM to a file, see Export Licensing Information on page 38.

• The file determines which additional license options that are available for the
device. It can also be used to view the current license options of the device
in the license web.

• From the license web, a license file containing the license keys for the de-
vice is generated.

• The license file is imported to the WinPDM, see Import Licenses on page
38.

• The WinPDM communicates the license key (included in the license file) to
the device

• The device upgrades according to the license options.
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4.8.3.1 Export Licensing Information

The information needed for licensing of a device can be exported to a product
information file. This file can be used to generate licenses for the device.

1) Click the Licenses tab.
2) Select the device(s) that shall be exported.
3) From the License menu, select Export.
4) Enter a name for the file and then click the Save button.

4.8.3.2 Import Licenses

License files are used for upgrading devices with licenses. A license file can be
imported to the WinPDM.

1) From the File menu, select Import > Licenses.
2) Select the license file(s) to be imported (*.xml) and then click the Open but-

ton.

4.8.4 View License Options

It is possible to view which license options that exist on a device.

1) Click the Licenses tab.
2) Select the device which license(s) to be shown.

In the bottom of the work area, the license options of the device are listed and
whether the options are enabled or not. To change an option, you have to up-
date the license on the License web.

4.8.5 Filter License Options

It is possible to search and select devices which have same license options.
The selected devices can be upgraded with additional licenses by exporting a
product information file to the License Web (see Export Licensing Information
on page 30). The advantage to select devices with same license options is that
additional licenses can be applied for the devices simultaneously.

1) Click the Licenses tab.
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2) Click the Advanced find button.

A License options filter window opens.

3) Under Device types section, select device(s) to be included in the filter.
4) Under Option filters section, select the status of the license option(s) that

shall be common for the selected devices.
5) • Ignore — show all devices independent of license options.

• Enabled — show devices with a certain license option enabled.
• Disabled — show devices with a certain license option disabled.

The search result is updated directly when selecting devices and license op-
tions. In addition, the icon  is also displayed next to the Advanced find but-
ton to indicate that the search result is filtered.

When clicking Close, the filtered search result will still be displayed. When
clicking Reset, the filter is removed and all devices are displayed.

4.8.6 Refresh

If a device is already registered in the WinPDM and a change of licenses has
been done, the information needs to be updated. By doing a Refresh, the de-
vice license information in WinPDM is synchronized with the information in the
License server and transferred to the device.

NOTICE:  This feature requires a connection to the license serv-
er.

1) Click the Licenses tab.
2) Select device(s) which licenses to be refreshed.
3) From the License menu, select Refresh.

The correct license is fetched from the license server, sent to the device and
displayed in the WinPDM.
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4.8.7 Remove Devices from the License View

This command removes devices from the licenses tab view.

1) Click the Licenses tab.
2) Select the devices(s) that shall be removed from the list.
3) From the License menu, select Remove device.
4) In the Remove device window, click the Yes button.

4.8.8 Move License

This feature requires WinPDM that supports the move license feature, and a
connection to the license server.

INFO:  See also the device’s manual for more information on
which device that support this feature.

If supported by the device, a license can be moved from one device to anoth-
er device of the same device type. This feature can for example be used if your
device is broken and you want to move the license to another device.

1) Click the Licenses tab.
2) Select the device which license that should be moved.
3) From the License menu, select Move license.
4) Select the device that shall receive the license. Click the OK button. If no de-

vices are shown in the Move license window, there are no devices that are
selectable to move the license to.

The device type of the device that received the license is still unchanged in
the WinPDM. Select this device and do the following:

5) From the License menu, select Refresh to complete the transfer of the li-
cense. The device type of the device is now updated in WinPDM.

4.9 File Management

This chapter covers File management for parameter definition files, software
files, language files (.lng) for devices, and company phonebook files.

Import and export of templates and numbers are described in Import and Ex-
port of Numbers and Templates on page 44. Import of language files (.xml)
for the WinPDM menu are described in Language Settings for WinPDM GUI on
page 21.

The parameter definition file holds the definitions of all parameters for a specific
version of a Number’s parameter set. Updated software and new parameter de-
finition files for devices and Numbers can be added to the WinPDM, see Import
Parameter Definition Files on page 41.

A31003-M2000-J108-01-7631, 26/06/2020
40 Portable Device Manager, Installation and Operation Manual



Operation

Figure 14: The File management window

4.9.1 Definition File Version — Parameter Version

Both definition files and device software include parameters and are indicated
by a version number.

If a device associated to a Number is upgraded to a software supporting an-
other parameter version than the stored Number, it does not always demand a
new definition file. An old definition file can often be used, but if new parameters
have been added in the new parameter version these parameters will not be ed-
itable. The release note will tell you if a new definition file is needed to match
the new parameters. If the old definition file cannot be used, it will be highlighted
with red.

4.9.2 Import a Package File

A package file may include different types of files, such as software files, para-
meter definition files and/or template files. If the package does not include a cer-
tain file, it can be imported separately. See Import Parameter Definition Files on
page 41, Import New Software Files for Devices on page 42, and/or Im-
port Templates on page 44.

1) From the File menu, select File management.
2) Select the Parameter definition tab or Software tab and click the Add but-

ton.
3) Select the package file (.pkg) to be imported and click the Open button.

The files included in the package are now imported.

4.9.3 Import Parameter Definition Files

TIP: Parameter definition files (.def) are mainly included in package files (.pkg)
distributed by your supplier, see Import a Package File on page 41.

1) From the File menu, select File management.
2) Select the Parameter definition tab and click the Add button.
3) Select the definition file (.def) to be imported and click the Open button. Only

files with a corresponding extension are shown, such as .def and .pkg.
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4.9.4 Import New Software Files for Devices

TIP: Software files (.bin) are mainly included in package files (.pkg) distributed
by your supplier, see Import a Package File on page 41

1) From the File menu, select File management.
2) Select the Software tab and click the Add button.
3) Select the software file to be imported and click the Open button. Only files

with a corresponding extension are shown, such as .bin and .pkg.

To apply the software for a device, continue with the instruction in Upgrade a
Device with New Software on page 42.

4.9.5 Upgrade a Device with New Software

It is possible to upgrade the software in a device. The device must be on-
line/logged in to WinPDM.

1) Click the Devices tab.
2) Select the device which should be upgraded. It is possible to select several

devices, but only devices of the same device type can be selected.
3) From the Device menu, select Upgrade.
4) In the Available files drop-down list, select the software to be uploaded.

NOTE: If the software is not available, you can import it by clicking the Im-
port button.

5) Click the OK button.

The software will be downloaded to the device. A progress bar in the Status col-
umn for the device shows the progress of the download. The device will restart
automatically after a successful download.

To cancel the upgrade, select Device > Cancel upgrade.

4.9.6 Import Language Files for Devices

NOTICE:  To select the language to be used in the WinPDM,
see The WinPDM GUI on page 17.

For adding a new language to a device, a language file (.lng) distributed by your
supplier must be imported to the WinPDM and then uploaded to the device.

1) From the File menu, select File management.
2) Click the Language tab and then click the Add button.
3) Select the language files to be imported and click the Open button. Only files

with a corresponding extension are shown, such as .lng.

To apply the language for a device, continue with the instructions in Upload a
Language to Devices on page 42.

4.9.7 Upload a Language to Devices

It is possible to upload a language to devices that support this feature.
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1) Click the Devices tab.
2) Select the device(s) to upload a language to. It is possible to select several

devices, but only devices of the same device type can be selected.
3) From the Device menu, select Upload Language.
4) In the Available files drop-down list, select which language to upload.

NOTE: If your language is not available in the drop-down list, the language
file (.lng) can be imported by clicking the Import button.

5) Click the OK button.

4.9.8 Import Company Phonebook Files

It is possible to import a company phonebook file for later use. 

1) From the File menu, select File management.
2) Click the Company Phonebook tab and click the Add button.
3) Select the company phonebook files (.cpb) to be imported and click the

Open button.

To upload the company phonebook to a device, continue with the instructions in
Upload a Company Phonebook on page 43.

4.9.9 Upload a Company Phonebook

It is possible to upload the company phonebook to a device that supports this
feature. The company phonebook will appear in the device’s Contacts list.

1) Click the Devices tab.
2) Select the device(s) to upload a company phonebook to. It is possible to se-

lect several devices, but only devices of the same device type can be select-
ed.

3) From the Device menu, select Upload company phonebook.
4) In the Available files drop-down list, select which company phonebook to be

uploaded.

NOTICE:  If your company phonebook is not available in the
drop-down list, the company phonebook file (.cpb) can be im-
ported by clicking the Import button.

5) Click the OK button.

4.9.10 Delete Imported Files for Devices

It is possible to delete parameter definition files, software files, language files
(.lng) for devices, and company phonebook files.

1) From the File menu, select File management.
2) Select the applicable tab.
3) Select the file(s) to be deleted.
4) Click the Delete button.
5) In the Delete files window, click the Yes button.
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4.10 Import and Export of Numbers and Templates

This section describes import and export of Numbers and templates.

• Import and export of licensing information is described in Licenses on page
36.

• Import and additional file handling of parameter definition files, software files,
language files and company phonebook files for devices are described in
File Management on page 40.

• Import of language files for WinPDM are described in Language Settings for
WinPDM GUI on page 21.

The purpose of exporting and importing Numbers and templates is to be able to
move Numbers and templates to another site or to use at a later time.

The parameter configuration in Numbers can be exported to a file. This file can
be used by the supplier to pre-program devices before delivery to the customer,
and to share Numbers and templates with other PDMs.

4.10.1 Import Numbers

Updated Number files may be distributed by your supplier.

1) From the File menu, select Import > Numbers.
2) Select the Number file(s) to be imported (*.xcp) and click the Open button.

If there is a Number conflict when importing Numbers, the error message Num-
ber import failed: Number already exists is displayed.

4.10.2 Export Numbers to a File

It is possible to configure Numbers for a site and export the settings to a file.
One or several Numbers can be selected. The exported file can then be used
when producing new devices for the customer. Only Numbers stored in the
database can be exported. There is no restriction on device type when export-
ing.

1) Click the Numbers tab.
2) Select the Number(s) to be exported
3) From the Number menu, select Export.
4) Enter a file name for the Numbers (.xcp) and where to save the file and click

the Save button.

4.10.3 Import Templates

Updated template files may be distributed by your supplier.

1) From the File menu, select Import > Templates.
2) Select the template files to be imported (*.tpl) and click the Open button.

If there is a naming conflict when importing a template, the new template is im-
ported and a digit within brackets is added after the name. The old template’s
name is not affected.

For example:
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• Template MyHandset (old template)
• Template MyHandset (2) (new template)

4.10.4 Export Templates

It is possible to export template files. One or several templates can be exported.

1) Click the Templates tab.
2) Select the template (or templates) to be exported.
3) From the Template menu, select Export.
4) Enter a file name for the templates (.tpl) and where to save the file and click

the Save button.
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5 Administration

5.1 Data Backup

All settings in the WinPDM, such as the configuration, the sites and the tem-
plates are stored as database files. It is recommended to do backups on a reg-
ular basis. Device software, definition files, templates, devices and Numbers in-
cluding parameters are included in the backup.

5.1.1 Backup WinPDM Database Files

1) Close the WinPDM.
2) The database files are saved in the WinPDM folder located in: C:\USERS

\<USER>\APPDATA\ROAMING\ASAB\
3) Copy the WinPDM folder to, for example, a network drive.

5.1.2 Restore WinPDM Database Files

1) Close the WinPDM.
2) Retrieve the saved copy of the WinPDM folder.
3) Copy the WinPDM folder to: C:\USERS\<USER>\APPDATA\ROAMING\ASAB

\
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6 Uninstall the WinPDM
In Windows, select to uninstall WinPDM. Refer to the vendor documentation for
more information how to uninstall a program.
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7 Troubleshooting
When troubleshooting the WinPDM, it is always a good idea to examine the log
files, since they provide additional information that may prove useful. When re-
porting an error to your supplier, always include the appropriate log file.

Log files are stored under

C:\USERS\<USER>\APPDATA\ROAMING\ASAB\WinPDM\log

The log files are rotated every 10 MB and are time-stamped with 1 ms resolu-
tion:

Fault Action or comment

The WinPDM does not start or installa-
tion fails

To run the WinPDM, the computer
must confirm to the requirements list-
ed in Requirements on page 7. If you
do not have the correct software ver-
sions installed, contact your system
administrator. To install the WinPDM,
you must have administrator rights on
the computer. Contact your system
administrator if you are not able to in-
stall the WinPDM.

Firewall alerts appear every time Win-
PDM is started.

Windows Firewall may alert you of
“PMServer” etc. You can ignore these
security alerts, it will not affect the
WinPDM, but then the alerts will ap-
pear every time the WinPDM is start-
ed. A better way is to select “Contin-
ue blocking” or “Unblock”.

Connected device does not appear in
WinPDM.

Make sure the device is properly con-
nected, or try disconnecting and re-
connecting the device. Make sure
that the USB port is configured cor-
rectly as follows: - In Windows, open
the Device Manager, refer to the ven-
dors documentation. If the device
does not show up in the list (as an
USB port controlled device depend-
ing on the handset model), check the
connection and reinstall the drivers
and/or software for the device.
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A device’s software is not recog-
nized/synchronization fails

A device might have software with a
parameter set that is newer than the
version recognized by the WinPDM.
The WinPDM will then be unable to
send parameters to the device. The

symbol  in the Status column for
the selected device indicates that the
synchronization between the device
and the WinPDM was not success-
ful. If this is the case, the WinPDM
should be updated with new software
and definition files provided by your
local supplier. See Import a Package
File on page 41.

Upgrade of a device’s software fails
(aborted)

The device does not support the soft-
ware version. Use another software
version. Ask your supplier.

A Parameter conflict dialog window ap-
pears

If a device is detected and the same
Number has been used by another
device in the system there will be a
parameter conflict. A dialog window
appears, asking the user to decide
whether to use the Number settings
in WinPDM or the Number settings
in the device. One typical situation
when this parameter conflict will oc-
cur is if a device’s hardware has been
replaced. For example: A replace-
ment device has first been registered
with the same Number as the dam-
aged device. When the replacement
device is connected to the WinPDM,
the WinPDM will warn for a parame-
ter conflict. In this case, select “Win-
PDM” to transfer the phonebook of
the damaged device (located in Win-
PDM) to the new device. If “Device”
is chosen in this situation, the phone-
book belonging to the damaged de-
vice and located in WinPDM will be
deleted (and replaced with the emp-
ty phonebook in the replacement de-
vice). For more information about de-
vice replacement, see the User Man-
ual or Configuration Manual for re-
spective device.
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8 Related Documents
Data Sheet, Portable Device Manager (WinPDM), Windows Version

Configuration Manual for your handset

User Manual for your handset

Installation and Operation Manual/Installation Guide for your charger or desktop
programmer
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9 Appendix A: WinPDM Keyboard Shortcuts

9.1 General

Shortcut Description

Ctrl + H Open the File management window.

Ctrl + Tab Switch tab

Alt + F4 Close the application

9.2 Devices

Shortcut Description

Ctrl + N Add a new device

Enter Upgrade the selected device(s)

Delete Delete the selected device(s)

Ctrl + F Find a device

Ctrl + Enter Open the Properties window for the selected device

9.3 Numbers

Shortcut Description

Ctrl + N Add a new Number

Enter Edit the selected Number

Ctrl + C Copy the selected Number

F2 Rename the selected Number

Ctrl + S Save the selected Number to the database

Delete Delete the selected Number from the database

Ctrl + F Find a Number

9.4 Templates

Shortcut Description

Ctrl + N Add a new template
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Enter Edit the selected template

Ctrl + C Copy the selected template

F2 Rename the selected template

Delete Delete the selected template

Ctrl + F Find a template

9.5 Licenses

Shortcut Description

Delete Delete the selected license(s)

Ctrl + F Find a license
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10 Appendix B: File Types
In this appendix, the different file extensions that are used in WinPDM are ex-
plained. System files are not described.

File type Extension Description

Software file (de-
vices)

bin Software for devices

Company Phone-
book file

cpb Company Phonebook file for portable de-
vices.

Parameter Defini-
tion file

def Including all possible settings for a certain
device type for a certain version.

Language file lng, or xml Language file for portable devices or Win-
PDM. Language file for WinPDM uses XML
(eXtensible Markup Language.).

Package file pkg Archive that can include different file types
such as parameter definition files (.def), soft-
ware files (.bin) and template files (.tpl).

Site file ste Storage for site specific data. These files
may not be edited manually.

Template file tpl Contains one or more exported templates.

Number file xcp Exported Numbers.

Product informa-
tion file

xml A file containing information needed for li-
censing and upgrade of a device.

License informa-
tion file

xml A file containing license keys for devices.
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